Obrir sessió
logo

DEFENSA DAVANT DE LES CIBERAMENACES

barra-separadora

Soporte de vulnerabilidades

Servicio de soporte de vulnerabilidadesAnálisis, notificación y seguimiento de aquellas vulnerabilidades más críticas, que impactan especialmente en las tecnologías empleadas en el sector público. El CCN-CERT trabajará en la recopilación y clasificación de las nuevas vulnerabilidades, realizando un análisis teórico y en laboratorio, cuando sea posible, de aquellas que por su criticidad lo requieran.

Se generarán documentos informativos o “abstracts” de dichas vulnerabilidades y se llevará a cabo un seguimiento de la evolución de la vulnerabilidad en Internet, alertando a los organismos ante cambios en la criticidad, aparición de parches, nuevas recomendaciones, constancia de explotaciones activas, etc.

Para inscribirse en este servicio o recibir más información, escribir al correo electrónico: soporte_acreditacion@ccn.cni.es

Abstracts:


Boletines de Vulnerabilidades


Vulnerabilidad en uim

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Aumento de privilegios
Dificultad Experto
Requerimientos del atacante Acceso remoto con cuenta

Información sobre el sistema

Propiedad Valor
Fabricant afectat GNU/Linux
Software afectado uim <0.4.5.1

Descripción

Se ha descubierto una vulnerabilidad en las versiones anteriores a la 0.4.5.1 de uim. La vulnerabilidad reside en que uim siempre confía en las variables de entorno.

La explotación de esta vulnerabilidad podría permitir a un atacante local ejecutar código arbitrario mediante una aplicación que utilice libuim. El atacante podrá elevar sus privilegios si se trata de una aplicación setuid o setgid.

Se debe destacar que el problema sólo es explotable en aplicaciones qt con qt-immodule.

Solución

Si lo desea, aplique los mecanismos de actualización propios de su distribución, o bien baje las fuentes del software y compílelo usted mismo.


Actualización de software

uim
uim 0.4.5.1
http://uim.freedesktop.org/releases/uim-0.4.5.1.tar.gz

Mandrake Linux

Mandrakelinux 10.1
x86
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/10.1/RPMS/libuim0-0.4.5.1-0.1.101mdk.i586.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/10.1/RPMS/libuim0-devel-0.4.5.1-0.1.101mdk.i586.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/10.1/RPMS/uim-0.4.5.1-0.1.101mdk.i586.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/10.1/RPMS/uim-applet-0.4.5.1-0.1.101mdk.i586.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/10.1/SRPMS/uim-0.4.5.1-0.1.101mdk.src.rpm
X86_64
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/x86_64/10.1/RPMS/lib64uim0-0.4.5.1-0.1.101mdk.x86_64.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/x86_64/10.1/RPMS/lib64uim0-devel-0.4.5.1-0.1.101mdk.x86_64.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/x86_64/10.1/RPMS/libuim0-0.4.5.1-0.1.101mdk.i586.rpm
ftp://ftp.ps.pl/mirrors/Mandrakelinux/official/updates/x86_64/10.1/SRPMS/uim-0.4.5.1-0.1.101mdk.src.rpm

Identificadores estándar

Propiedad Valor
CVE CAN-2005-0503
BID 12604

Recursos adicionales

uim Security Advisory
http://lists.freedesktop.org/archives/uim/2005-February/000996.html

Mandrakesoft Security Advisories MDKSA-2005:046
http://www.mandrakesoft.com/security/advisories?name=MDKSA-2005:046

Histórico de versiones

Versión Comentario Data
1.0 Aviso emitido 2005-02-25
Tornar

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración