int(910)

Boletines de Vulnerabilidades


Desbordamiento de búfer en pavuk

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Obtener acceso
Dificultad Avanzado
Requerimientos del atacante Acceso remoto sin cuenta a un servicio exotico

Información sobre el sistema

Propiedad Valor
Fabricant afectat GNU/Linux
Software afectado pavuk 0.9pl28
pavuk 0.9pl27

Descripción

Se ha descubierto una vulnerabilidad de desbordamiento de búfer en las versiones 0.9pl28 y 0.9pl27 de pavuk, una herramienta para descarga de ficheros mediante HTTP, HTTPS, FTP o Gopher. La vulnerabilidad reside en el manejo de la cabecera "Location:" cuando un servidor envía una respuesta HTTP 305.

La explotación de esta vulnerabilidad podría permitir a un atacante remoto ejecutar código remotamente con los privilegios del proceso pavuk mediante un servidor Web que sirva un archivo especialmente diseñado que la víctima debe descargar.

Solución



Actualización de software

Debian Linux

Debian Linux 3.0
Source archives
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1.dsc
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1.diff.gz
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28.orig.tar.gz
Alpha
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_alpha.deb
ARM
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_arm.deb
Intel IA-32
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_i386.deb
Intel IA-64
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_ia64.deb
HP Precision
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_hppa.deb
Motorola 680x0
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_m68k.deb
Big endian MIPS
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_mips.deb
Little endian MIPS
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_mipsel.deb
PowerPC
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_powerpc.deb
IBM S/390
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_s390.deb
Sun Sparc
http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_sparc.deb

Identificadores estándar

Propiedad Valor
CVE CAN-2004-0456
BID

Recursos adicionales

Ulf Härnhammar message
http://seclists.org/lists/fulldisclosure/2004/Jul/0078.html

Debian Security Advisory DSA 527-1
http://lists.debian.org/debian-security-announce/debian-security-announce-2004/msg00128.html

Histórico de versiones

Versión Comentario Data
1.0 Aviso emitido 2004-07-05
Ministerio de Defensa
CNI
CCN
CCN-CERT