int(532)

Boletines de Vulnerabilidades


Denegación de servicio en Cisco PIX

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Denegación de Servicio
Dificultad Experto
Requerimientos del atacante Acceso remoto sin cuenta a un servicio estandar

Información sobre el sistema

Propiedad Valor
Fabricant afectat Networking
Software afectado Cisco PIX firewall

Descripción

Se ha descubierto dos vulnerabilidades en el software de Cisco PIX, la primera referente al protocolo SNMPv3 (documentado por Cisco como CSCeb20276) y la segunda afecta a VPNC (documentado por Cisco como CSCec20244/CSCea28896).

Todos los firewalls Cisco PIX están afectados por estas vulnerabilidades.
La vulnerabilidad del SNMPv3(CSCeb20276) afecta a las versiones de Cisco PIX firewall software 6.3.1, 6.2.2 y anteriores, 6.1.4 y anteriores, 5.x.x y anteriores.

La vulnerabilidad de VPNC (CSCec20244/CSCea28896) afectada a las versiones de Cisco PIX firewall software 6.2.3 y anteriores. Las versiones 6.1.x y 5.x.x no están afectadas ya que no implementan VPNC

Detalles Técnicos

CSCeb20276 (SNMPv3)
En el firewall Cisco PIX se produce la caída o reinicio de este sistema al procesar un mensaje SNMPv3 , cuando snmp-server host está configurado sobre este equipo. Esto se debe a que estos sistemas no soportan SNMPv3.

VPNC(CSCec20244/CSCea28896 )
Bajo ciertas condiciones una conexión establecida por un VPNC con un túnel IPSec cae si otro cliente IPSec intenta iniciar la fase de negociación de IKE con la interfaz del Firewall PIX configurada como cliente VPN. Sólo los firewalls Cisco PIX configurados como clientes VPN son vulnerables a este fallo.
Una conexión VPNC, también llamada Easy VPN o ezVPN, se crea cuando un firewall Cisco PIX se usa como cliente VPN para conectarse a un servidor VPN.

El fallo CSCea28896 se resuelve en las versiones de software PIX 6.3.x , y el CSCec20244 en las versiones de software 6.2(3.100) y posteriores

Solución



Actualización de software

Para la vulnerabilidad CSCeb20276 (SNMPv3)
Actualizar Cisco PIX software a las versiones 6.3.2 y posteriores, 6.2.3 y posteriores, 6.1.5 y posteriores.
Una Solución temporal es deshabilitar ln servicio SNMP del Firewall Cisco PIX

Para la vulnerabilidad CSCec20244/CSCea28896 (VPNC)
Actualizar Cisco PIX software a las versiones 6.3.1 y posteriores, 6.2(3.100) y posteriores.

Descarga de actualizaciones
El procedimiento para actualizar el software se describe en
http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/index.htm

Identificadores estándar

Propiedad Valor
CVE CAN-2003-1003
CAN-2003-1004
BID

Recursos adicionales

Cisco Security Advisory Document ID: 47284
http://www.cisco.com/warp/public/707/cisco-sa-20031215-pix.shtml

Histórico de versiones

Versión Comentario Data
1.0 Aviso emitido 2003-12-16
Ministerio de Defensa
CNI
CCN
CCN-CERT