Obrir sessió
logo

DEFENSA DAVANT DE LES CIBERAMENACES

barra-separadora

Soporte de vulnerabilidades

Servicio de soporte de vulnerabilidadesAnálisis, notificación y seguimiento de aquellas vulnerabilidades más críticas, que impactan especialmente en las tecnologías empleadas en el sector público. El CCN-CERT trabajará en la recopilación y clasificación de las nuevas vulnerabilidades, realizando un análisis teórico y en laboratorio, cuando sea posible, de aquellas que por su criticidad lo requieran.

Se generarán documentos informativos o “abstracts” de dichas vulnerabilidades y se llevará a cabo un seguimiento de la evolución de la vulnerabilidad en Internet, alertando a los organismos ante cambios en la criticidad, aparición de parches, nuevas recomendaciones, constancia de explotaciones activas, etc.

Para inscribirse en este servicio o recibir más información, escribir al correo electrónico: soporte_acreditacion@ccn.cni.es

Abstracts:


Boletines de Vulnerabilidades


Denegación de servicio en la librería zlib

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Obtener acceso
Dificultad Avanzado
Requerimientos del atacante Acceso remoto sin cuenta a un servicio exotico

Información sobre el sistema

Propiedad Valor
Fabricant afectat GNU/Linux
Software afectado Caldera OpenLinux Server 3.1, 3.1.1
Caldera OpenLinux Workstation 3.1, 3.1.1
GLT GLT 0.6
NetBSD 1.5, 1.5.1, 1.5.2, 1.5.3, 1.6
NullSoft Winamp 2.79
OpenPKG 1.1, 1.2

Descripción

Se ha detectado una vulnerabilidad en la librería zlib utilizada por muchos programas de compresión.

La versión 1.1.4-1 y posiblemente otras son vulnerables a un ataque de denegación de servicio provocada por un desbordamiento de búfer en la función gzprintf(). Dicha vulnerabilidad se da cuando se le introduce un valor igual o mayor a 4096 bytes a la función gzprintf() de zlib. Beneficiandose de esta vulnerabilidad un potencial atacante puede provocar un desbordamiento de búfer causando la caida del programa que utiliza la librería zlib o permitiendo la ejecución de código arbitrario.

Solución



Actualización de software

Kelledin Hotfix
zlib-1.1.4-3-vsnprintf.patch
http://www.securityfocus.com/data/vulnerabilities/patches/zlib-1.1.4-3-vsnprintf.patch

OpenPKG:
Actualizar a la última versión disponible de zlib
ftp://ftp.openpkg.org/release/1.1/UPD/zlib-1.1.4-1.1.1.src.rpm
ftp://ftp.openpkg.org/release/1.2/UPD/zlib-1.1.4-1.2.1.src.rpm

Caldera UnixWare 7.1.1, 7.1.3, y OpenUnix 8.0.0:
Actualizar a la última versión disponible (1.1.4-2 o posterior)
ftp://ftp.sco.com/pub/updates/OpenLinux/3.1.1/Server/CSSA-2003-011.0/RPMS

Mandrake Linux
Mandrake Linux 7.2 and Single Network Firewall 7.2: 1.1.3-11.2mdk o posterior
Mandrake Linux 8.0 and 8.1: 1.1.3-16.2mdk o posterior
Mandrake Linux 8.2 and Multi Network Firewall 8.2: 1.1.3-19.1mdk o posterior
Mandrake Linux 9.0 and Corporate Server 2.1: 1.1.4-5.1mdk o posterior
ftp://ftp.univie.ac.at/systems/linux/Mandrake/updates/

NetBSD
NetBSD 1.5
ftp://ftp.netbsd.org/pub/NetBSD/security/patches/SA2003-004-zlib-1.5.patch
NetBSD 1.6
ftp://ftp.netbsd.org/pub/NetBSD/security/patches/SA2003-004-zlib-1.6.patch

Identificadores estándar

Propiedad Valor
CVE CAN-2003-0107
BID NULL

Recursos adicionales

ISS security advisory #11381: zlib gzprintf() buffer overflow
http://www.iss.net/security_center/static/11381.php

BugTraq: poc zlib sploit just for fun
http://marc.theaimsgroup.com/?l=bugtraq&m=104610337726297&w=2

MandrakeSoft Security Advisory MDKSA-2003:033 : zlib
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2003:033

Caldera security advisory CSSA-2003-011.0: Linux: format string vulnerability in zlib (gzprintf)
ftp://ftp.sco.com/pub/security/OpenLinux/CSSA-2003-011.0.txt

Histórico de versiones

Versión Comentario Data
1.0 Aviso emitido 2003-03-27
Tornar

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración