Obrir sessió
logo

DEFENSA DAVANT DE LES CIBERAMENACES

barra-separadora

Soporte de vulnerabilidades

Servicio de soporte de vulnerabilidadesAnálisis, notificación y seguimiento de aquellas vulnerabilidades más críticas, que impactan especialmente en las tecnologías empleadas en el sector público. El CCN-CERT trabajará en la recopilación y clasificación de las nuevas vulnerabilidades, realizando un análisis teórico y en laboratorio, cuando sea posible, de aquellas que por su criticidad lo requieran.

Se generarán documentos informativos o “abstracts” de dichas vulnerabilidades y se llevará a cabo un seguimiento de la evolución de la vulnerabilidad en Internet, alertando a los organismos ante cambios en la criticidad, aparición de parches, nuevas recomendaciones, constancia de explotaciones activas, etc.

Para inscribirse en este servicio o recibir más información, escribir al correo electrónico: soporte_acreditacion@ccn.cni.es

Abstracts:


Boletines de Vulnerabilidades


Vulnerabilidad en el kernel de FreeBSD

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Aumento de la visibilidad
Dificultad Experto
Requerimientos del atacante Acceso remoto con cuenta

Información sobre el sistema

Propiedad Valor
Fabricant afectat UNIX
Software afectado FreeBSD <5.4-RELEASE

Descripción

Se ha descubierto una vulnerabilidad en las versiones anteriores a la 5.4-RELEASE de FreeBSD.

La vulnerabilidad se da en el kernel del sistema operativo ya que en múltiples puntos se tratan nombres como cadenas acabadas en carácter nulo (de tamaño variable) pero se pasan a las aplicaciones como buffers de tamaño fijo sin rellenar previamente de ceros la parte no usada de dichos buffers.

La explotación de esta vulnerabilidad podría permitir a un atacante local obtener partes de la memoria del kernel lo que le podría dar acceso a información sensible del sistema.

Solución



Actualización de software

FreeBSD
FreeBSD 4.x
ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/patches/SA-05:08/kmem4.patch
FreeBSD 5.x
ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/patches/SA-05:08/kmem5.patch

Identificadores estándar

Propiedad Valor
CVE CAN-2005-1406
BID NULL

Recursos adicionales

FreeBSD Security Advisory FreeBSD-SA-05:08.kmem
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-05:08.kmem.asc

Histórico de versiones

Versión Comentario Data
1.0 Aviso emitido 2005-05-06
Tornar

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración