int(1401)

Boletines de Vulnerabilidades


Múltiples desbordamientos de entero en PuTTY

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Obtener acceso
Dificultad Experto
Requerimientos del atacante Acceso remoto sin cuenta a un servicio estandar

Información sobre el sistema

Propiedad Valor
Fabricant afectat GNU/Linux
Software afectado PuTTY <=0.56

Descripción

Se han descubierto múltiples vulnerabilidades de desbordamiento de entero en la versión 0.56 y anteriores de PuTTY. Las vulnerabilidades residen en la implementación sftp.

La primera de las vulnerabilidades se debe a una falta de validación de la entrada del usuario que es utilizada posteriormente por la función memcpy. El fallo se encuentra en la función sftp_pkt_getstring() en sftp.c

La segunda de las vulnerabilidades se debe a un falta de validación de la entrada del usuario que es utilizada posteriormente por la función malloc. El fallo se encuentra en la función fxp_readdir_recv().

La explotación de estas vulnerabilidades podría permitir a un atacante remoto ejecutar código arbitrario mediante el uso de un servidor especialmente diseñado al que la víctima se debe conectar.

Solución



Actualización de software

PuTTY
PuTTY 0.57
http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Identificadores estándar

Propiedad Valor
CVE CAN-2005-0467
BID

Recursos adicionales

PuTTY vulnerability vuln-sftp-string
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-sftp-string.html

PuTTY vulnerability vuln-sftp-readdir
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-sftp-readdir.html

iDEFENSE Security Advisory 02.21.05 ID 201
http://www.idefense.com/application/poi/display?id=201&type=vulnerabilities

Histórico de versiones

Versión Comentario Data
1.0 Aviso emitido 2005-02-22
Ministerio de Defensa
CNI
CCN
CCN-CERT