Abrir sesión
logo

DEFENSA FRONTE ÁS CIBERAMEAZAS

barra-separadora

Soporte de vulnerabilidades

Servicio de soporte de vulnerabilidadesAnálisis, notificación y seguimiento de aquellas vulnerabilidades más críticas, que impactan especialmente en las tecnologías empleadas en el sector público. El CCN-CERT trabajará en la recopilación y clasificación de las nuevas vulnerabilidades, realizando un análisis teórico y en laboratorio, cuando sea posible, de aquellas que por su criticidad lo requieran.

Se generarán documentos informativos o “abstracts” de dichas vulnerabilidades y se llevará a cabo un seguimiento de la evolución de la vulnerabilidad en Internet, alertando a los organismos ante cambios en la criticidad, aparición de parches, nuevas recomendaciones, constancia de explotaciones activas, etc.

Para inscribirse en este servicio o recibir más información, escribir al correo electrónico: soporte_acreditacion@ccn.cni.es

Abstracts:


Vulnerability Bulletins


Multiples Vulnerabilidades en thttpd

Vulnerability classification

Property Value
Confidence level Oficial
Impact Obtener acceso
Dificulty Avanzado
Required attacker level Acceso remoto sin cuenta a un servicio estandar

System information

Property Value
Affected manufacturer GNU/Linux
Affected software thttpd

Description

Se han descubierto dos vulnerabilidades en el servidor tiny HTTP de Debian :

Fuga de Información
thttpd es usado para hacer hosting virtual y un atacante puede reemplazar con una cabecera "Host:" con el pathname en lugar del hostname,con lo que provocaría que thttpd revele información del sistema y se pueda navegar en el disco entero


Ejecución de código arbitrario
Se ha encontrado un desbordamiento de búfer remoto que permite a un atacante sobreescribir parcialmente el registro EBP, provocando la ejecución de código arbitrario.

Solution

Obtenga las fuentes del software y compílelo usted mismo, o bien aplique los mecanismos de actualización propios de su distribución.


Actualización de software
thttpd
http://www.acme.com/software/thttpd/

Debian Linux

Debian Linux 3.0 "Woody"
Alpha:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_alpha.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_arm.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_i386.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_ia64.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_hppa.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_m68k.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_mips.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_mipsel.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_powerpc.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_s390.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_sparc.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_sparc.deb

Standar resources

Property Value
CVE CAN-2002-1562
CAN-2003-0899.
BID NULL

Other resources

Debian Security Advisory DSA-396-1
http://www.debian.org/security/2003/dsa-396

Version history

Version Comments Date
1.0 Aviso emitido 2003-11-03
Volver

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración