Abrir sesión
logo

DEFENSA FRENTE A LAS CIBERAMENAZAS

barra-separadora

Soporte de vulnerabilidades

Servicio de soporte de vulnerabilidadesAnálisis, notificación y seguimiento de aquellas vulnerabilidades más críticas, que impactan especialmente en las tecnologías empleadas en el sector público. El CCN-CERT trabajará en la recopilación y clasificación de las nuevas vulnerabilidades, realizando un análisis teórico y en laboratorio, cuando sea posible, de aquellas que por su criticidad lo requieran.

Se generarán documentos informativos o “abstracts” de dichas vulnerabilidades y se llevará a cabo un seguimiento de la evolución de la vulnerabilidad en Internet, alertando a los organismos ante cambios en la criticidad, aparición de parches, nuevas recomendaciones, constancia de explotaciones activas, etc.

Para inscribirse en este servicio o recibir más información, escribir al correo electrónico: soporte_acreditacion@ccn.cni.es

Abstracts:


Boletines de Vulnerabilidades


Vulnerabilidad en la utilidad "xfsdump" en Unix/Linux

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Compromiso Root
Dificultad Experto
Requerimientos del atacante Acceso remoto con cuenta

Información sobre el sistema

Propiedad Valor
Fabricante afectado UNIX
Software afectado Unix
Linux

Descripción

Se ha descubierto una vulnerabilidad en la utilidad "xfsdump" de Unix/Linux, que permite a un usuario local ganar privilegios de superusuario. Esta utilidad contiene herramientas administrativas para el sistema de archivos XFS y cuando se activan las cuotas en dicho sistema de archivos se ejecuta el programa "xfsdq". Este fallo es causado porque el programa "xfsdq" crea un archivo en la raíz del sistema de archivos que contiene información sobre las cuotas de una forma insegura. Un atacante local puede explotar esta vulnerabilidad y ganar privilegios de superusuario en el sistema.

Solución

De momento solo Debian, Mandrake y SGI han anunciado este problema aunque afecta potencialmente a todas las distribuciones Unix/Linux que usan "xfsdump".


Actualización de software:
1.- Aplique los parches de Linux Debian para esta vulnerabilidad:
http://www.debian.org/security/2003/dsa-283
2.- Aplique el parche de SGI para esta vulnerabilidad:
#5059 para IRIX: versiones 6.5.16m, 6.5.17m, 6.5.18m, 6.5.19m
#5060 para IRIX: versiones 6.5.16f, 6.5.17f, 6.5.18f, 6.5.19f
Nótese que la versión 6.5.20 de Irix no estará afectada por esta vulnerabilidad.
Encontrará estos parches en:
ftp://patches.sgi.com/support/free/security/patches/
3.- Aplique los parches de Mandrake para esta vulnerabilidad:
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2003:047

Identificadores estándar

Propiedad Valor
CVE CAN-2003-0173
BID NULL

Recursos adicionales

Linux Debian security advisory DSA 283-1 11/04/2003
http://www.debian.org/security/2003/dsa-283

SGI security advisory 20030404-01-P 10/04/2003
ftp://patches.sgi.com/support/free/security/advisories/20030404-01-P

MandrakeSoft Security Advisory MDKSA-2003:047
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2003:047

Histórico de versiones

Versión Comentario Fecha
1.0 Aviso emitido 2003-04-22
Volver

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración