Abrir sesión
logo

DEFENSA FRENTE A LAS CIBERAMENAZAS

barra-separadora

Soporte de vulnerabilidades

Servicio de soporte de vulnerabilidadesAnálisis, notificación y seguimiento de aquellas vulnerabilidades más críticas, que impactan especialmente en las tecnologías empleadas en el sector público. El CCN-CERT trabajará en la recopilación y clasificación de las nuevas vulnerabilidades, realizando un análisis teórico y en laboratorio, cuando sea posible, de aquellas que por su criticidad lo requieran.

Se generarán documentos informativos o “abstracts” de dichas vulnerabilidades y se llevará a cabo un seguimiento de la evolución de la vulnerabilidad en Internet, alertando a los organismos ante cambios en la criticidad, aparición de parches, nuevas recomendaciones, constancia de explotaciones activas, etc.

Para inscribirse en este servicio o recibir más información, escribir al correo electrónico: soporte_acreditacion@ccn.cni.es

Abstracts:


Boletines de Vulnerabilidades


Múltiples vulnerabilidades en phpMyAdmin

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Obtener acceso
Dificultad Experto
Requerimientos del atacante Acceso remoto sin cuenta a un servicio exotico

Información sobre el sistema

Propiedad Valor
Fabricante afectado GNU/Linux
Software afectado phpMyAdmin <= 2.7.0

Descripción

Se han descubierto múltiples vulnerabilidades en phpMyAdmin versión 2.7.0 y anteriores. Las vulnerabilidades son descritas a continuación:

- CVE-2005-4079: La vulnerabilidad reside en la emulación que se hace de "register_globals" que permite sobrescribir ciertas variables. Un atacante remoto podría ejecutar código arbitrario mediante la modificación de la variable "import_blacklist" en "grab_globals.php".

- CVE-2005-3665: La vulnerabilidad reside en múltiples fallos cross-site scripting (XSS). Un atacante remoto podría inyectar código HTML o Web Script arbitrario mediante (1) la variable HTTP_HOST o (2) varios scripts del directorio de librerías que se encargan del manejo de cabeceras.

- CVE-2005-3787: La vulnerabilidad reside en múltiples fallos cross-site scripting (XSS). Un atacante remoto podría inyectar código HTML o Web Script arbitrario mediante (1) el panel de autenticación basado en cookies, (2) el parámetro "title", o (3) el formulario de creación de tablas.

Solución



Actualización de software

Suse Linux
Las actualizaciones pueden descargarse mediante YAST o del servidor FTP oficial de Suse Linux

Debian

Debian Linux 3.1
Source
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3.dsc
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3.diff.gz
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2.orig.tar.gz
Architecture independent
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3_all.deb

Identificadores estándar

Propiedad Valor
CVE CVE-2005-3665
CVE-2005-3787
CVE-2005-4079
BID 15735
15761

Recursos adicionales

SUSE Security Advisory (SUSE-SA:2006:004)
http://www.novell.com/linux/security/advisories/2006_04_phpmyadmin.html

Debian Security Advisory (DSA 1207-2)
http://lists.debian.org/debian-security-announce/debian-security-announce-2006/msg00311.html

Histórico de versiones

Versión Comentario Fecha
1.0 Aviso emitido 2006-01-31
1.1 Aviso emitido por Debian (DSA 1207-1) 2006-11-10
1.2 Aviso actualizado por Debian (DSA 1207-2) 2006-11-20
Volver

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración