Abrir sesión
logo

DEFENSA FRENTE A LAS CIBERAMENAZAS

barra-separadora

Boletines de Vulnerabilidades


Múltiples vulnerabilidades en Wordpress

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Denegación de Servicio
Dificultad Principiante
Requerimientos del atacante Acceso remoto sin cuenta a un servicio estandar

Información sobre el sistema

Propiedad Valor
Fabricante afectado GNU/Linux
Software afectado Wordpress <= 2.2.1
Wordpress <= 2.1

Descripción

Se han descubierto múltiples vulnerabilidades en Wordpress. Las vulnerabilidades son descritas a continuación:

- CVE-2007-3639: Se ha descubierto una vulnerabilidad en Wordpress 2.2.1 y anteriores. La vulnerabilidad reside en un error en la validación de la entrada en el parámetro "_wp_http_referer" del fichero "wp-pass.php". Un atacante remoto podría redirigir a los visitantes a sitios Web externos y obtener información sensible mediante una página Web especialmente diseñada.

- CVE-2007-4153: Se han descubierto múltiples vulnerabilidades de tipo Cross-Site Scripting en WordPress 2.2.1. La vulnerabilidad reside en un error en la validación de la entrada en los ficheros "options.php" y "link-import.php". Un atacante local con permisos de administrador podría inyectar código javaScript o HTML arbitrario a una página Web a través del Panel de Administración o mediante una URL especialmente diseñada utilizando en parámetro "opml_url".

- CVE-2007-4154: Se ha descubierto una vulnerabilidad en WordPress 2.2.1. La vulnerabilidad reside en un error en los ficheros "options-general.php", "options-writing.php", "options-reading.php", "options-discussion.php", "options-privacy.php", "options-permalink.php" y "options-misc.php". Un atacante local con permisos de administrador podría inyectar comandos SQL arbitrarios mediante una entrada especialmente diseñada en el parámetro "page_options".

- CVE-2007-0540: Se ha descubierto una vulnerabilidad en WordPress en versiones anteriores a la 2.1. La vulnerabilidad reside en un error de diseño del "Pingback". Un atacante remoto podría causar una denegación de servicio mediante una llamada al servicio pingback con una URI de origen que corresponde a un fichero binario, este fichero es descargado a pesar de no contener ningún dato de pingbak útil. Existe un exploit público disponible.

- La vulnerabilidad reside en un error no especificado de validación de entrada. Un atacante local podría acceder a la interfaz de administración mediante métodos no especificados.

Solución



Actualización de software

Debian (DSA-1564-1)

Debian Linux 4.0
Source
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10.orig.tar.gz
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch2.diff.gz
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch2.dsc
Arquitectura independiente
http://security.debian.org/pool/updates/main/w/wordpress/wordpress_2.0.10-1etch2_all.deb

Identificadores estándar

Propiedad Valor
CVE CVE-2007-3639
CVE-2007-4153
CVE-2007-4154
CVE-2007-0540
BID 22220

Recursos adicionales

Debian Security Advisory (DSA-1564-1)
http://lists.debian.org/debian-security-announce/2008/msg00138.html

Histórico de versiones

Versión Comentario Fecha
1.0 Aviso emitido 2008-05-08
Volver

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración