Abrir sesión
logo

DEFENSA FRENTE A LAS CIBERAMENAZAS

barra-separadora

Boletines de Vulnerabilidades


Escalada de privilegios en invscout de AIX

Clasificación de la vulnerabilidad

Propiedad Valor
Nivel de Confianza Oficial
Impacto Compromiso Root
Dificultad Principiante
Requerimientos del atacante Acceso remoto con cuenta

Información sobre el sistema

Propiedad Valor
Fabricante afectado UNIX
Software afectado IBM AIX 5.1.0
IBM AIX 5.2.0
IBM AIX 5.3.0

Descripción

Se ha encontrado una vulnerabilidad de ruta no confiable en el comando setuid invscout incluido por defecto en varias versiones de IBM AIX.

La vulnerabilidad se debe a que invscout ejecuta la aplicación "lsvpd" sin abandonar privilegios y esta última a su vez ejecuta el comando "uname" desde las rutas especificadas por el usuario en la variable de entorno PATH.

La explotación de esta vulnerabilidad podría permitir a un atacante ejecutar código arbitrario como usuario root.

Solución



Actualización de software

AIX

AIX 5.1.0:
APAR IY64852
http://www-912.ibm.com/eserver/support/fixes/fcgui.jsp

AIX 5.2.0:
APAR IY64976
http://www-912.ibm.com/eserver/support/fixes/fcgui.jsp

AIX 5.3.0:
APAR IY64820
http://www-912.ibm.com/eserver/support/fixes/fcgui.jsp

Identificadores estándar

Propiedad Valor
CVE CAN-2004-1054
BID NULL

Recursos adicionales

iDEFENSE Security Advisory (12.20.04)
http://www.idefense.com/application/poi/display?id=171&type=vulnerabilities&flashstatus=true

Histórico de versiones

Versión Comentario Fecha
1.0 Aviso emitido 2004-12-21
2.0 Exploit público disponible 2005-06-01
Volver

Este sitio web utiliza cookies propias y de terceros para el correcto funcionamiento y visualización del sitio web por parte del usuario, así como la recogida de estadísticas. Si continúa navegando, consideramos que acepta su uso. Puede cambiar la configuración u obtener más información. Modificar configuración